Frequently Asked Questions

Why am I getting the error that my graphics need OpenGL 3.2?
Last Updated 2 years ago

If you've installed Planetary Annihilation, but you are receiving an error that your graphics drivers and/or hardware are missing critical OpenGL capabilities, it may be the case that your graphics card driver is outdated.

To make sure you have the latest graphics card driver installed, please go directly to the manufacturer to download and install the latest driver:

* For integrated Intel GPUs:
https://downloadcenter.intel.com/default.aspx

* For Nvidia GPUs:
http://www.nvidia.com/Download/index.aspx

* For ATI/AMD GPUs:
http://support.amd.com/us/gpudownload/Pages/index.aspx


If you've installed the latest graphics card driver, but you are still receiving this error, it may be the case that your graphics card does not meet the Minimum System Requirements to play the game. If you are unsure, please contact Support. 

Please Wait!

Please wait... it will take a second!